Hello,**My name is Dave. I am writing for my friend Joe Mythos who has purchased and us...

GetHuman783582's customer service issue with Blizzard from June 2018

1 view
 | 
150 similar
 | 
0 following
Help with my Blizzard issue
First: share to improve GetHuman783582's odds
Strength in numbers! Companies respond better when others are watching.
GetHuman783582's next move: try the Blizzard help center again.
Blizzard doesn't have a customer phone number that is answered by an agent. Instead, GetHuman783582 will want to follow the link below to head to their help center. We will check on GetHuman783582 later to make sure it's all set or try to help escalate.
Before contacting them, items GetHuman783582 may need:
Email on Account, Username, Password, Game Name, Console, Game Version Type, and Name of Account Holder
The issue in GetHuman783582's own words
Hello,**My name is Dave. I am writing for my friend Joe Mythos who has purchased and used your Diablo III game on his computer, windows * previously and Windows ** x** now.**The Motherboard died and was replaced. It is now running an MSI *** Gaming board. I am including the system hardware profile as well as the dxdiag results to this message.**The machine is running Windows ** Home ** bit. We tried to install Diablo III via the dvd and it would not work, it could not find battle.net. We are wondering if there's been a dns change to battle.net that the dvd does not reflect? Network connections to the internet are fine, we flushed the dns and reloaded the IP, tried again, and still the dvd would not work. Question, is UPNP a requirement?**We then downloaded your desktop launcher app from your site and tried that. It fails, with this error code:**blzbntbts*******d**I've confirmed that the secondary logon service is running, malware bytes* was removed to get that potential issue out of the way, neither of these worked. At one time, on wireless the machine said it was downloading, but it never moved, no progress bar, just sat there. So I then did a disk cleanup, and removed previous game files, thinking the download was corrupted. On ethernet I'm getting nothing. I have tried enabling UPNP both on the computer itself, as well as on the router, no good. I have also on the win** host set up the port forwards as described at:**https:**us.battle.net*support*en*article*******I've seen forum posts on this but not a solution. **Another time we got the following error code:**blzbntbts*******a**I've tried selective startup as listed in the forums, nothing.**I'd appreciate any help. I have included text attachments of the system's hardware profile as well as the system's dxdiag. All the drivers, chipset, graphics, audio, networking, Bios, are all up to date.**Thanks.*Dave.
GetHuman783582 did not yet indicate what Blizzard should do to make this right.
I have an issue with Blizzard too
How GetHuman783582 fixed the problem
We are waiting for GetHuman783582 to fix the problem and share the solution with the rest of us customers.
Follow this to see how it gets fixed
Do you have a customer issue as well?
We can help you get Blizzard's attention and get better help faster. Tap below to get started.
Having Blizzard issues too?
Get tips from pros & other customers, and get it handled faster:
For better results, write at least 100 characters
How would Blizzard email you?
This email address isn't valid
Follow this issue
See how GetHuman783582 fixes it.
This email address isn't valid

Blizzard

Customer service issue
Reported by GetHuman783582
Jun 14th, 2018 - 9 mons ago
I have an issue with Blizzard too
Not resolved
Seen by 1 customer so far
Similar issue to 150 others
0 customers following this
Follow this issue to see how it gets fixed
Timeline
GetHuman783582 started working on this issue
Jun 14th, 2018 1:12pm