I have a U-Phoria UMC***HD USB input which I've used without problem for years on two d...

GetHuman5318815's Device Support issue with Behringer from September 2020

8 views | 449 similar | 0 following
Help with my Behringer issue
First: share to improve GetHuman5318815's odds
Strength in numbers! Companies respond better when others are watching.
GetHuman5318815's next move: talk to Behringer when they open.
Behringer's call center is closed now. We will send GetHuman5318815 a reminder to call them when they open. Nothing to do for now but wait!
If time is of the essence or you are lost, we partner with a California-based expert help company with tech support available 24/7. Enjoy a $1 one-week trial membership and get help from a live person now: Talk now with an expert.
Before contacting them, items GetHuman5318815 may need:
Name on the account, Product ID Number, Product Name, and Billing Address
Top Tip from another customer
If you are having technical difficulties with your Verizon services please reset your phone or bring the phone into the Verizon store. If the issue is with cell service please check your area to see if Verizon is down.
The issue in GetHuman5318815's own words
I have a U-Phoria UMC***HD USB input which I've used without problem for years on two different Macs, an older MacMini and a brand new MacBook Pro. Both are updated to the current version of Catalina. I recorded audio through both yesterday as normal. I recorded to the MacMini in the morning and then to the MacBook Pro in the early afternoon. Then, yesterday evening, I tried to record to the MacMini, but it would not recognize the U-Phoria. I reinstalled the OS and tried again, with the same problem. This afternoon, I tried using the MacBook Pro, and the same thing--the machine does not recognize the interface at all. It's like it's not there. I tried a different cable to no avail. I record to Logic, but I also checked the Sound preferences in the System and also the Audio MIDI Setup program, but it did not recognize it.**I contacted Apple support and they reported no firmware updates in the last ** hours and suggested that the device is the problem, somewhat predictably. **How might I go from here? Have other users experienced anything similar recently? I've never had any problems whatsoever with the U-Phoria until now. **Thank you for your help!**My best,**William Foreman

GetHuman5318815 did not yet indicate what Behringer should do to make this right.

How GetHuman5318815 fixed the problem

We are waiting for GetHuman5318815 to fix the problem and share the solution with the rest of us customers.

Do you have a customer issue as well?
We can help you get Behringer's attention and get better help faster. Tap below to get started.
Help from Real People?
If our free tools aren't enough, we partner with a US-based company with live tech support experts available 24/7. Take advantage of a $1 one-week trial membership and chat with an expert now.
Chat with a Live Expert
Having Behringer issues too?
Get tips from pros & other customers, and get it handled faster:
For better results, write at least 100 characters
This email address isn't valid
Follow this issue
See how GetHuman5318815 fixes it.
This email address isn't valid

Behringer

Device Support issue
Reported by GetHuman5318815
Sep 30th, 2020 - 2 years ago
Not resolved
Seen by 8 customers so far
Similar issue to 449 others
0 customers following this

Timeline

GetHuman5318815 started working on this issue
Sep 30th, 2020 10:45pm