I recently moved into a hme which has a new Honeywell Focus Pro **** thermostat. It wor...

GetHuman-tknccn's customer service issue with Honeywell from October 2018

Help with my Honeywell issue
The issue in GetHuman-tknccn's own words
I recently moved into a hme which has a new Honeywell Focus Pro **** thermostat. It worked fine for cooling. Now that it is cold, I switched to heat. No matter what temperature I set above **, it shows ** as the current temperature, and it feels like it. I can set it lower and it goes lower, although it's hard to tell the difference so I don't know if it is working at all. Perhaps the heater wire wasn't connected correctly?
GetHuman-tknccn did not yet indicate what Honeywell should do to make this right.
I have an issue with Honeywell too
How GetHuman-tknccn fixed the problem
We are waiting for GetHuman-tknccn to fix the problem and share the solution with the rest of us customers.
Please help with my Honeywell issue
Do you have a customer issue as well?
We can help you get Honeywell's attention and get better help faster. Tap below to get started.
Having Honeywell issues too?
Get tips from pros & other customers, and get it handled faster:
For better results, write at least 100 characters
How would Honeywell email you?
This email address isn't valid

Honeywell

Customer service issue
Reported by GetHuman-tknccn
Oct 18th, 2018 - a mon ago
I have an issue with Honeywell too
Fixed
Seen by 6 customers so far
Similar issue to 242 others
0 customers following this
Items needed
Where was the item purchased
Order number (if applicable)
Billing address
Timeline
GetHuman-tknccn started working on this issue
Oct 18th 8:30pm
GetHuman-tknccn indicated the issue is not fixed yet.
Oct 20th 12:07pm