I order Conversion struts for a **** Yukon XL they came, and I got the customer SUV in...

GetHuman810356's customer service issue with Am-Autoparts.com from June 2018

Help with my Am-Autoparts.com issue
The issue in GetHuman810356's own words
I order Conversion struts for a **** Yukon XL they came, and I got the customer SUV in two install them and went I open up the box’s both Sensors were missing two bolts and nuts for the lower part of the struct I’m not so concerned about the bolts and nuts but the sensors I can’t install them withhold it so I contacted Am auto parts and told them what happen they apologized and told me they would refund my money or check to find them parts and it would take * to * business days they also said they would give a shipping label to return the parts I have not heard from them for over a week I think at this time I need a shipping label and return the parts in my refund my money they told me to referred this number AMORDO*******
GetHuman810356 did not yet indicate what Am-Autoparts.com should do to make this right.
I have an issue with Am-Autoparts.com too
How GetHuman810356 fixed the problem
We are waiting for GetHuman810356 to fix the problem and share the solution with the rest of us customers.
Please help with my Am-Autoparts.com issue
Do you have a customer issue as well?
We can help you get Am-Autoparts.com's attention and get better help faster. Tap below to get started.
Having Am-Autoparts.com issues too?
Get tips from pros & other customers, and get it handled faster:
For better results, write at least 100 characters
This email address isn't valid

Am-Autoparts.com

Customer service issue
Reported by GetHuman810356
Jun 29th, 2018 - 10 mons ago
I have an issue with Am-Autoparts.com too
Fixed
Seen by 2 customers so far
Similar issue to 349 others
0 customers following this
Items needed
Account name
Email address
Shipping Address
Order number
Account phone number
Timeline
GetHuman810356 started working on this issue
Jun 29th, 2018 11:48pm
GetHuman810356 indicated the issue is not fixed yet.
Jun 29th, 2018 11:48pm