my Product to Repair*GIGABYTE AORUS GA-AX***-Gaming K* *(AMD Ryzen AM** is not working...

GetHuman-cus's customer service issue with Gigabyte from June 2018

Help with my Gigabyte issue
my Product to Repair*GIGABYTE AORUS GA-AX***-Gaming K* *(AMD Ryzen AM** is not working Motherboard does not post tried all troubleshooting i can do.***Remove everything from the back of the computer, except the power cable. Turn on the computer and see if it beeps normally. **Disconnect my power cables from any power strip or UPS and connect the computer directly to a known good wall outlet.* *Put everything together fully, CPU slipped into its socket like they were meant to be together. And, of course, they were. **At this point I've triple-checked the connections. Front panel power button is responsive. **I've tried different DIMM arrangements, in order of distance from closest to CPU (as in, CPU-Slot*-Slot*-Slot*-Slot*:**,***,***,***,***Also tried a few single DIMM arrangements with each DIMM on different slots. *I've tried getting a display with both the HDMI port and the DisplayPorts on the Radeon. Nothing. **So right i am stuck with this with on one to help me**wanted to get a toll fee number aside from *-***-******* because no one answering the line
I trust that Gigabyte will make this right and come up with a resolution that is fair.
Help with my Gigabyte issue
Do you have a customer issue as well?
We can help you get Gigabyte's attention and get better help faster. Tap below to get started.
Having Gigabyte issues too?
Get tips from pros & other customers, and get it handled faster:
For better results, write at least 100 characters
How would Gigabyte email you?
This email address isn't valid

Gigabyte

Customer service issue
Reported by GetHuman-cus
Jun 5th, 2018 - 2 mons ago
I have an issue with Gigabyte too
Fixed
Seen by 11 customers so far
Similar issue to 648 others
0 customers following this
Items needed
Where was the item purchased
Order number (if applicable)
Billing address
Timeline
GetHuman-cus started working on this issue
Jun 5th 8:45pm
GetHuman-cus indicated the issue is not fixed yet.
Jun 6th 12:51pm
GetHuman-cus indicated the issue is not fixed yet.
Jun 6th 4:30pm
GetHuman-cus indicated the issue is not fixed yet.
Jun 6th 5:27pm
GetHuman-cus indicated the issue is not fixed yet.
Jun 6th 5:28pm
GetHuman-cus indicated the issue is not fixed yet.
Jun 6th 5:34pm
GetHuman-cus indicated the issue is not fixed yet.
Jun 13th 2:33pm
GetHuman-cus indicated the issue is not fixed yet.
Jun 13th 5:54pm
GetHuman-cus indicated the issue is not fixed yet.
Jun 13th 7:05pm