I can't seem to figure out how to install the * *** saw blade on the Portr cable **vol...

GetHuman-loudigi's customer service issue with Delta/Porter Cable from August 2018

7 views
 | 
28 similar
 | 
0 following
Help with my Delta/Porter Cable issue
How did GetHuman-loudigi do it?
Waiting to hear how GetHuman-loudigi fixed the problem to share with other customers.
The issue in GetHuman-loudigi's own words
install the saw blade ... I can't seem to figure out how to install the * *** saw blade on the Portr cable **volt pcc*** circular saw. there's got to be something so simple I cant see it...I've got lots of power tools. is there a video link I could view?... Love your product!!!
saw blade can't seem to pass by the lower blade guard
a video link would suffice
I own every one of the **v tools in the product line
I have an issue with Delta/Porter Cable too
How GetHuman-loudigi fixed the problem
We are waiting for GetHuman-loudigi to fix the problem and share the solution with the rest of us customers.
Follow this to see how it gets fixed
Do you have a customer issue as well?
We can help you get Delta/Porter Cable's attention and get better help faster. Tap below to get started.
Having Delta/Porter Cable issues too?
Get tips from pros & other customers, and get it handled faster:
For better results, write at least 100 characters
How would Delta/Porter Cable email you?
This email address isn't valid
Follow this issue
See how GetHuman-loudigi fixes it.
This email address isn't valid

Delta/Porter Cable

pcc*** **VOLT CIRC SAW
Customer service issue
Reported by GetHuman-loudigi
Aug 25th, 2018 - 4 mons ago
I have an issue with Delta/Porter Cable too
Fixed
Seen by 7 customers so far
Similar issue to 28 others
0 customers following this
Follow this issue to see how it gets fixed
Items needed
Where was the item purchased
Order number (if applicable)
Billing address
Timeline
GetHuman-loudigi started working on this issue
Aug 25th 11:41pm
GetHuman-loudigi indicated the issue is not fixed yet.
Aug 26th 12:58am
GetHuman-loudigi confirmed the issue is fixed. Hooray!
Aug 26th 8:40pm