Hi, I bought a N**E*********** at Newegg: CORSAIR ML*** PRO RGB, ***mm Premium Magnetic...

GetHuman-jegarst's Technical support issue with Corsair from July 2019

Help with my Corsair issue
First: share to improve GetHuman-jegarst's odds
Strength in numbers! Companies respond better when others are watching.
The issue in GetHuman-jegarst's own words
Hi, I bought a N**E*********** at Newegg: CORSAIR ML*** PRO RGB, ***mm Premium Magnetic Levitation RGB LED PWM Fan, CO-*******-WW. *-Pack with Lighting Node PRO.*I configured them with a new motherboard build atop (flow upward) rather than below an H***i radiator in place of the black fans. They were in an old ***D case with * Dominator Platinum rgb DDR* sticks aside a K** platinum RGB keyboard, an mm*** rgb polaris mousepad with Glaive rgb mouse. Besides a fantastically capable motherboard and build, it looked wonderful all in sync until about the third day that is, when all three fans lost their rgb. The fans still run and, although the lighting node pro was still present in iCue, swapping the fans from positions *-* to *-* made no difference. I have checked and double checked the wiring to no avail. Strange that all three fan rgbs were lost, but doesn’t that suggest the lighting node pro failed? Any troubleshooting suggestions or should we just replace the rgb fan kit?

GetHuman-jegarst did not yet indicate what Corsair should do to make this right.

How GetHuman-jegarst fixed the problem

We are waiting for GetHuman-jegarst to fix the problem and share the solution with the rest of us customers.

Do you have a customer issue as well?
We can help you get Corsair's attention and get better help faster. Tap below to get started.
Having Corsair issues too?
Get tips from pros & other customers, and get it handled faster:
For better results, write at least 100 characters
This email address isn't valid

Corsair

Technical support issue
Reported by GetHuman-jegarst
Jul 27th, 2019 - 2 years ago
Not resolved
Seen by 17 customers so far
Similar issue to 123 others
0 customers following this
Items needed
Where was the item purchased
Order number (if applicable)
Billing address

Timeline

GetHuman-jegarst started working on this issue
Jul 27th, 2019 2:33pm
GetHuman-jegarst indicated the issue is not fixed yet.
Jul 27th, 2019 8:40pm
GetHuman-jegarst indicated the issue is not fixed yet.
Jul 28th, 2019 3:15pm
GetHuman-jegarst indicated the issue is not fixed yet.
Jul 28th, 2019 4:08pm
GetHuman-jegarst indicated the issue is not fixed yet.
Jul 29th, 2019 4:51am
GetHuman-jegarst indicated the issue is not fixed yet.
Jul 29th, 2019 4:51am
GetHuman-jegarst indicated the issue is not fixed yet.
Jul 30th, 2019 6:00pm
GetHuman-jegarst indicated the issue is not fixed yet.
Aug 10th, 2019 2:42am
GetHuman-jegarst indicated the issue is not fixed yet.
Aug 10th, 2019 2:42am